Use the non-beta loader, idk why but that fixed my issue.